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Introduction

Garmin BaseCamp for PC is a free program that can be downloaded from the Garmin website.  There are versions for both
PC and Mac. BaseCamp for PC is usually supplemented with a topo map product from Garmin. Garmin has been updating
BaseCamp for PC several times each year, sometimes significantly changing the user interface.

The current Garmin topo map products applicable to our area are:

Garmin TOPO U.S. 24K Southwest
Garmin MapSource TOPO U.S. 24K Arizona/New Mexico
Garmin TOPO U.S. 100K

You can also use Garmin compatible maps from GPSFileDepot .

The instructions and screenshots in this section are based on using the PC version of BaseCamp for PC 4.6.2 (updated on
February 2016) with Garmin TOPO U.S. 24K Southwest. 

There are some nice things about BaseCamp for PC:



Ability to preview the result of joining tracks.
Access to data for each trackpoint.
An Undo option.
Ability to easily reverse a track.

BaseCamp for PC is especially useful if you are recording tracks on one of the newer devices with better antennas/chips,
such as Garmin GPSMap 62 or 64, and after checking the elevation profile you feel confident that you've gotten accurate
elevation data.

Other helpful websites that explain how to use Garmin BaseCamp for PC are:

https://garminbasecamp.wikispaces.com

http://static.garmincdn.com/basecamp/en/Default.htm

Setup

Steps:

On the top menu, left click on Edit, then Options, then Measurement.1. 
Select Measurement System - Statute. The program then fills in the appropriate units for a number of other
parameters.
Select Grade→Percentage.
Select Heading→True.
Select Position→Grid "Lat/Lon hddd° mm.mmm'" and Position→Datum "WGS 84".

From the same screen, click on Display.2. 
For Tooltips, check to display additional information in map tooltips.
Select Rendering Quality→High.
Select Labels half way between Fewer & More.
Select Symbol Size→Medium.
Select Track Width→Medium or Track Width→Thick.
Select Map Font→Select button, and choose a font such as Microsoft Sans Serif or Arial, Bold, and a font size
that works for the waytrack you have.  You may need to increase the font for long in-out hikes. Click the OK
button.
For 3D Elevation Exaggeration, select 100%.

Click the OK button to exit.3. 

It's recommended that you create a folder (such as My Hikes) in My Documents or other directory and save your hike files
there.  Delete everything listed under My Collection in BaseCamp for PC after you've finished (or before you start)
working on a hike.

Enable Toolbars

On the top menu, left click on View, then move the cursor to Toolbars. Check all of the options except for those involving
Areas, Activities, or Playback. You can rearrange groups of icons by moving the cursor to the far left of a group until you
see a cross shape. Then click & drag the group to where you want it to be. I've rearranged my set so that icons I use
infrequently are to the far right. Some of the icons will be active only if a track is selected.

The icons of interest to us in creating hike descriptions are shown below.



Toolbar symbols and their meaning (from left to right, left side of toolbar):

Topo map chosen
Level of map detail
Insert
Move point
Erase
Divide
Cut
Copy
Paste
Delete

Toolbar symbols and their meaning (from left to right, right side of toolbar):

Undo
Redo
Hand (Pan, move track in the window)
Magnifying glass (Zoom)
Arrow (Select)
Ruler (Measure)
New waypoint
New route
New track
Send to device
Receive from device

Import GPS Data

To import GPS data from a file:

Steps:

Click on My Collection, and Select File→Import.1. 
Select the file on the hard drive (several file types are supported, including .gpx).2. 

(BaseCamp for PC will automatically download data from a GPS that is connected before the program starts up. These data
are listed under Devices. )

Export GPS Data

You may export everything shown under My Collection, or select specific waypoints and/or tracks.



Steps:

Choose what you want to be exported (export everything in My Collection is the default).1. 
Left-click on the My Collection folder on the upper left hand corner of the screen.2. 
Left-click on File on the left-most item on the top menu.3. 
Choose Export.4. 
If you have selected specific items, you can choose Export Selection.5. 
Rename the file as appropriate, and save it in a folder on your hard drive.6. 

Set Color of Track

After importing a track, select the track by double-clicking on it. Then select the color in the small box at the upper right of
the trackpoints window. (Dark Red is the preferred color for the track in a map posted on the ASCHG website created in
BaseCamp.)

Edit a Waypoint Label

Steps:

Right click on the waypoint, and choose Rename.1. 
Edit the waypoint name.2. 

Delete a Waypoint

Steps:

Right click on the waypoint, and choose Delete.1. 

Add a Waypoint

Steps:

On the toolbar, click on the icon with a flag.  The cursor should be a white arrow with a little box at the upper right.1. 
Position the tip of the white arrow where you want to create the new waypoint, and left click.2. 

Copy a Waypoint or Track - Garmin BaseCamp for PC

You might want to use tracks or waypoints belonging to one hike as part of another hike. To do this, first create a new list
by right clicking on My Collection and choose New list. You can import existing tracks and waypoints into the New list.

To copy a waypoint or track into the New list:

Steps:

Select the waypoint or track to copy, and choose Copy.1. 
Select the New list, then choose Paste.2. 
You then can export the contents of the New list, which now include the additional waypoints and/or tracks.3. 

List Waypoints with Data

Steps:

Double click on the waypoint in the listing on the left-hand-side of the screen.1. 



Select and copy the waypoint name and paste it into a text file followed by a colon.2. 
Copy the coordinates and past them next to the waypoint name.3. 
Add a comma between the latitude and longitude values.4. 

If you also have the Garmin MapSource program, you can use that to get all of the waypoints at one time.

Steps:

Select all of the waypoints.1. 
Right-click, then copy & paste into a text editor or the waypoints text field on the website data input form.2. 
Edit out line starting with "Symbol & Name", the duplicate waypoint name, add a colon after the waypoint name,
and add a comma between the latitude and longitude values.

3. 

Draw a Track

Steps:

Left click on the Track icon (two footprints). The cursor turns into a pencil.1. 
Move the cursor then left click anywhere you want a trackpoint.  The software draws a straight line between
trackpoints. Or, left click and hold to draw a continuous line.

2. 

Right-click to stop drawing the track.3. 
Click on the hand (Pan) or arrow (Select) icons to turn off the pencil and return the cursor to normal.4. 

Reverse a Track

Steps:

If you want to save the original track, copy it by right-clicking on the track name and choose Duplicate. A track with
the original name with 001 will appear in the My Collection listing.

1. 

Left-click on the track that you want to reverse.  Right click to bring up a list of possible actions, and select Invert
Selected Track.

2. 

Note that the red direction arrows along the track have changed direction.3. 
Rename the track to reflect its new direction.4. 

Split a Track

Steps:

Import the track you want to split.1. 
Double click on the file name next to the feet icon in the lower left of the screen.  The track should be displayed on a
topo map in the main window.

2. 

In the top menu, choose the Divide icon.3. 
Click on the map in the location where you want to split the file.  In the left track data window, you should see a feet
icon with "Track" next to it.  You now have two tracks.  If you save the file at this point, there are two separate
tracks.

4. 

Turn off Divide by clicking on the Hand (Pan) icon.5. 
The tracks will show up as different shades of the color you chose for your tracks.6. 
Left click on the track name you want to delete, and then right click on Delete in the popup menu.7. 

Join Tracks

Steps:

Import the tracks that you want to join.  You'll have a chance to check that you're joining the tracks in the correct1. 



order or to reverse one of the tracks during the join process.  The remaining discussion is based on two tracks.
Click on My Collection in the upper left of the screen.  Both tracks should be listed in the tracks data window.2. 
Left click on the first track, and then hold down Ctrl and left click on the second track.  Both tracks should be
selected.

3. 

Right click, then choose Join the Selected Tracks. The topo map will display the way the joined track will look if you
click OK. Check the direction of the arrows to make sure it's what you want. If it is, then click OK in the popup Join
Tracks box. If it isn't, try reversing one of the tracks, then joining them.

4. 

You have the option to delete the original tracks or save them along with the joined track.5. 

Say you have a one-way track that you want to make into an in-out track.  Let's use Piedra Lisa as the example.  Import the
one-way track twice, giving each copy a unique name, and go through the steps up to the Join Tracks - Track box.  Note
that the preview of the joined track doesn't look right.  You'll need to reverse one of the tracks.

To reverse the first track, click on the curving arrow icon on the left-hand side of the popup window.  The information note
about the joined track shows it starting at the north end (the order that the reversed track and the original track are listed). 
If you want the tracks to be joined to start at the south trailhead, move the top track to the bottom using the up or down



directional arrow icons in the left side of the Join Tracks - Track popup window.

Click OK. You now have a new track named "Track"

Clean a Track

I prefer to use the detailed trackpoints listing to delete one or a group of trackpoints rather than the Eraser tool.

Steps (for individual trackpoints):

To look for trackpoints to delete, double click on the track to bring up the trackpoints window and see the individual
track points along the track.

1. 

Zoom in, and use the hand icon (Pan) to move the track in the window until you see a trackpoint visibly off the
expected track.

2. 

Click on the arrow icon (Select) then on the trackpoint of interest. An orange circle should appear around the point.3. 



Locate the highlighted trackpoint in the trackpoints window to select it, and then press the Delete key on the
keyboard.

4. 

Steps (for a group of trackpoints):

One group of trackpoints to always delete are those registered by the GPS device during lunch. You can usually
locate those with recorded times starting between 11:30 AM and noon for a 30 min period. The "break" trackpoints
should have recorded velocities near zero.

1. 

To delete a group of trackpoints, select them by holding down the shift key and clicking on the first and last of the
trackpoints in the trackpoints window.

2. 

Press the Delete key to delete all of them.3. 

This is one way to clean up stray trackpoints that are recorded when you are stationary, such as during lunch. (To find
these, look for a 30 min interval with very low velocity values for the trackpoints.)

An additional cleaning step is to reduce the number of trackpoints to 500, both to remove "jitter" and to make it easier for
hikers who have Garmin GPSMap 60CSx hand-held GPSs to download the track from the ASCHG website. Another way
to do this is to simplify the track using GPSBabel (add link).

Steps:

Double-click on the track to open the trackpoints window. Look in the Summary box for Points.1. 
If the number of points (trackpoints) is greater than 500, you can use BaseCamp for PC to simplify the track.2. 
Click on the Filter button near the bottom left of the trackpoints window.3. 
Just in case something goes wrong, check the box at the bottom left hand corner of the gray popup window. A
duplicate of your current track appears in the list under MyCollection.

4. 

For "Filter by," check "Automatic." If the number of trackpoints is much greater than 500, move the slider to the far
right ("More points"). If not, choose "Fewer points."

5. 

Then click OK.6. 
Repeat until the number of trackpoints is 500 or less.7. 



You can compare the elevation profile of the simplified track to that of the original one. Notice the change in the
Ascent/Descent values. Simplifying the track has reduced those values.

8. 

Add Elevation Data to Track File

The default for Garmin BaseCamp for PC is to use elevation data recorded by the GPS and to display the track using the
topo map from the selected map software such as Topo U.S. 24K Southwest. You should always review the elevation
profile (select "Graph" from the detailed Track file) to see if it makes sense. (For example, an in-out hike should begin and
end at the same elevation.)

If there are a few wayward trackpoints, you can edit them out. If the track shows a lot of jagged lines, your GPS may not be
receiving the satellite signals clearly or may be having problems interpreting them correctly. You can create a better track
file by replacing this incorrect set of elevations with those from Garmin's built-in Digital Elevation Model (DEM).

Steps:

Import the track into Garmin BaseCamp for PC with one of the 24K maps selected (such as Garmin Topo U.S. 24K
Southwest).

1. 

Select Edit→Advanced→Set Selected Track to Map Elevation. The elevation data shown now come from the DEM.
If the elevation profile now makes more sense, save the revised file.

2. 

Draw an Elevation Profile

Steps:

Double click on the track to bring up the detailed Track window.1. 
Choose the Graph option at the top of the window to view the Elevation Profile.2. 

You can save a copy of the Elevation Profile to the Clipboard, then paste it into an image-editing program. That's a fine
addition to the supplemental page of the hike description, especially for hikes that go up and down hills several times.



Determine Maximum and Minimum Elevations

after cleaning the track, double click on the track to bring up the detailed Track window. Read off the Max and Min values
from the Elevation box.

Determine Total Uphill/Total Downhill

Steps:

Clean the track to remove trackpoints that contain "artificial" elevation changes, such as those recorded during lunch,
and filter the track down to 500 trackpoints.

1. 

In the Track window, click on Properties.2. 
Read off the total uphill and total downhill values, which are given as "ascent" and "descent", respectively, in the
Elevation box.

3. 

Determine Average Grade



Garmin BaseCamp for PC doesn't compute average grade the way most other mapping software programs do – if you
return to the same trailhead, the average grade reported in the trackpoints window elevation box is reported near zero.

Steps:

Split your track into two pieces. The lunch spot is a good choice for loop hikes. For an in-out hike, choose the
turnaround point.

1. 

Determine the average grade for each piece (for an in-out hike, the grade in will be positive and the grade back will
be negative).

2. 

Use the steepest of the two values for the value to enter on the website.3. 

Determine Distance along the Track

Steps:

In the detailed Track window, click on Graph to bring up the Elevation Profile.1. 
If you move the cursor (now a white arrow) along the profile starting at the left, a red dot with an information notice
moves along the top. A hiker figure moves along the track in the main window (the one with the track shown on a
topo map). 

2. 

When the hiker figure has reached a waypoint, read off and record the distance along the track to that waypoint as
shown next to the dot on the elevation profile.

3. 

Draw a Map

Garmin BaseCamp for PC doesn't include a feature to export a map. You'll need to create a screenshot. Steps:

Adjust the track map until it takes up most of the available space on the screen. (Zoom in with left click; zoom out
with right click.) (You can make the map full-screen by choosing View→ Full Screen. Remember to press the F11
key to return to the previous screen.)

1. 

Use the hand icon to move the map on the screen.2. 



Hold down the keyboard keys Ctrl and PrtScn at the same time. This puts an image of the screen on the clipboard.3. 
Use an image-editing software program to crop, resize, and if necessary rotate the image by 90 deg for the map to
load onto the website.

4. 

Geotag Photos

If you took photos while recording a track with your Garmin device, you can match your photos to the track. BaseCamp for
PC uses the time information from your photos and your tracks to match your photo to a specific track point. Waypoints are
created automatically for each matched photo. You can also geotag your photos using the location information from your
track.

Steps:

Select a track.1. 
Select Edit→Geotag Photos using Track.2. 
Select Browse.3. 
Select one or more photos taken while you recorded the track, and select OK→Next.4. 
Select Create Waypoints for matched photos to create a waypoint for each photo.5. 
If necessary, select Timeshift to adjust the difference between the photo time stamps and the track time stamps.6. 
Select Next.7. 
Select Geotag Photos→Finish.8. 

The geotagged photos appear on the map.


